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Introduction 
WaveCart is the original on-screen, Cart Machine in use by thousands of broadcasters around the World 

and was even used at the Atlanta Olympic Games! 

 

WaveCart uses a standard PC and sound-card to play back multiple audio files, optionally to different 
audio outputs and can automatically sequence from one deck to another. 

Each of the decks has a label clearly showing information about the audio file being played and there are 

timers showing Elapsed, Remaining and even an Intro countdown. 

As well as up to 10 on-screen decks, an additional 24 HotKeys are available for frequently used audio 

files. 

Individual play decks or audio files can be triggered using the BSI Trigger Kit (or other optional 

hardware devices) making it easy to interface to satellite receivers, mixing consoles or button boxes etc.  
Up to 24 incoming triggers are available. 

Information about how to get started with WaveCart is explained in the QuickStart section. 

For any questions of a technical nature related to WaveCart, please refer to http://support.bsiusa.com  
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Getting Started 
Consult the following sections for information on installation, configuring, using and getting the most out 

of WaveCart.  

• Installation  

• Starting the program  

• QuickStart Guide  

• Adding New Files  

• Main Screen  

• Security Options  

• Event Logs  

• Registration & Validation  

• Support 

  

Installing WaveCart 

System Requirements 

The computer system needed to run WaveCart very much depends on exactly what you want to do.  

WaveCart will run on a wide range of computers, but some features will require more than a bare-bones 

minimum.   

Bare-bones Minimum    

Intel Core 2 Duo, 2.4Ghz Processor (we do not recommend AMD, Pentium or Celeron processors) 

Microsoft Windows XP Professional (we do not recommend using any operating system designed 
for Servers as these are not optimized for multimedia use) 

2GB memory  
USB Port (for Hardware Key)  

At least one Sound Card, with Wave or WDM Drivers on Windows XP, or WDM drivers on Windows 7+ 

Recommended Configuration    

Intel Core i3, 2.4Ghz or higher 

Windows Windows 7 Professional 32bit or 64bit or Windows 8/8.1 32bit or 64bit 
4GB RAM for 32bit operating systems, 8GB RAM for 64bit operating systems 

USB Port (for Hardware Key) 

2 x SATA Hard Drives (one for Windows, one for audio files) 
Professional Sound Card with multiple audio streams with WDM Drivers 
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Optimization 

Most off-the-shelf PCs are designed and configured for home or small office use.  The demands of a 

multimedia computer running 24/7 are very different.   

While WaveCart will run with either configuration, for maximum performance and long-term stability we 
highly recommend purchasing a correctly configured, custom multimedia PC directly from BSI. 

Our technical support department can assist you with any software or hardware purchased directly from 
BSI, but we cannot guarantee to assist you configuring computers purchased elsewhere and / or may 

make a charge for doing so. 

If you plan to supply and configure your own PC, we highly recommend obtaining a copy of the Microsoft 

Resource Kit and ensuring that you have optimized your computer for performance rather than 

appearance. 

Installation 

To Install WaveCart from the BSI Install CD, insert the CD into your CD-ROM drive. 

If you have disabled the autorun feature of your CD-ROM, run the setup.exe file on the CD. 

Use the drop-down box to select WaveCart and then click the Install button 

Follow the on-screen prompts, and selecting Full if you are installing for the first time, or Upgrade to 

preserve settings from a previous installation of WaveCart. 

IMPORTANT NOTE: 

WaveCart 5.0 requires a Hardware Key to validate the program.  Please ensure that you have installed the 

Sentinel Driver before trying to register the program.  You'll find a copy on the BSI Install CD and on 

the drivers page of our Web Site. 

Uninstalling 

To Uninstall WaveCart  

1. Click the Start button.  

2. Select Control Panel.  

3. Double-click Add/Remove Programs.  

4. Click Change or Remove Programs.  

5. Then select WaveCart from the list of programs that can be automatically removed.  

6. Click the Remove button to uninstall WaveCart.  

WaveCart's uninstall program will have deleted any files it created that are no longer is use by any other 

programs still installed on your PC. 

It will not delete any user generated files, including Audio Files, Events Logs, Stacks etc. 
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QuickStart 

Starting WaveCart 

 

To start WaveCart, click the WaveCart icon found in the Start menu, in 

Programs > Broadcast Software. 

You can also double-click the Desktop Icon. \ 

WaveCart installs some sample audio files* which by default are installed in 

c:\bsi32\audio.   

You'll see the sample audio files in the Audio List on the right-hand side 

of WaveCart's main window. 

 

If you have difficulty reading the details, Right-Click and select 

Change list font to select a larger font. 

 

To view more than just the Artist and Title, select Show Details from the 
same menu. You'll then be able to see more information about the audio 

file such as OutCue, Intro, Length and Start and End Dates.   

* To reduce size, the supplied sample audio files are 16-bit, 22Khz, Mono.  

When you add your own audio files, we suggest using 16-bit, 44.1Khz, 

Stereo files (linear PCM .wav) although WaveCart will also play MP3 and 

MPEG Layer 2 files (if your audio card supports MPEG Layer 2 playback, or 

if you have a suitable audio codec). 
 

To load audio files into the play decks, click the audio file and then the numbered button of the deck 

you wish to load. (You can also drag and drop the audio file into the play deck too). 

The control buttons will no longer be grayed out and you can Play, Pause, or Eject the audio file by 

clicking the relevant buttons. 

 

When a file is playing, the eject button is replaced by a Stop button. 



BSI WaveCart 5.1 Pro Manual 

Page 8 
 

Adding New Files 

As previously mentioned, sample audio files are installed in c:\bsi32\audio and any additional files 

saved into the same folder will appear in the Audio List. 

We recommend using a separate hard drive for your audio files and it's easy to configure WaveCart to 

monitor additional folders for new audio files using the companion SoundHound utility.  The utility 

constantly monitors selected folders for new or modified audio files and keeps WaveCart's Audio List 

up-to-date. 

 SoundHound is usually automatically launched when WaveCart starts and appears as a pair of 

binoculars in the System Tray. Double-click the icon to view SoundHound. 

 From the Folders tab click the Add a folder icon and browse to the folder you want to add.  We 

recommend using up to 8 folders and that all folders should be on your local hard drive.  While there are 

no physical limitations in WaveCart that prevent you doing otherwise, we are unable to support any issues 

arising out of your failure to adhere to our recommendations. 

 Rather than reference different folders by their actual paths, you can give each path a friendly name 

(for example, Songs, Spots, Sound Effects, etc.) and tell WaveCart to display the friendly name instead (in 
the Program Options). 

 When you no longer want to monitor a folder, highlight the folder you want to remove and click the 

Remove a folder icon. 

There are two diagnostic functions on the Folders tab which are useful when optimizing or trouble-

shooting your system. 

Firstly, the location and size of the Audio Database are easily obtained from this screen.  Over time, 

the database will increase and should be deleted (with WaveCart shut down).  It will be automatically 

rebuilt once WaveCart is restarted. 

Secondly, the Monitor column indicates whether or not there's a problem monitoring a particular 

folder.  If all is well, you'll see an OK in this column.  

 

NOTE: WaveCart has been designed to work optimally with the number of files most stations schedule, 

between 2,500 and 3,500.  We do not recommend using more than 5,000 files (the number of songs you 
can comfortably store on a single 250 GB hard drive) as performance will reduce after that point due, in 

part to the larger database. 
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Main Screen 
WaveCart's main screen displays up to 10 Play Decks and the Audio List. Use the Window > Optimize 

Display menu option to fit the maximum number of decks on screen. 

 

The left-hand scroll bar can be used to scroll the decks up and down if your display will not accommodate 

all ten decks on screen at the same time. 

The right-hand scroll bar is used to navigate through the list of audio files. 

Below the Audio List is the Pass-Through Mute button (this button can be hidden, so if you don’t see 

it, go to the Window menu and choose Display Pass-Through Control).  This button mutes or un-mutes a 

secondary source of audio input into your audio card’s line in, and output through its line out (hence pass-

through).  Right-clicking on the button will lock the current muted/unmuted state so that the auto-mute 
feature (if enabled) won’t change the pass-through mode if you don’t want it to. 

The Status Bar at the bottom of the user interface contains 10 deck position indicators and buttons for 
AutoStep, Loop, and TimeEvents. 
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AutoStep & Loop 

The AutoStep feature allows play decks to sequence automatically.  This is useful for segueing songs 

automatically, or running a spot break. 

Loop allows play back to continuously sequence through the decks (this relies on the Program Option to 
reload a deck once playback has finished).  This is especially useful where virtual carts are used and can 
form a rudimentary automation or sustaining service. 

The AutoStep and Loop indicators can also be used to toggle each option on and off.  Green 

indicates the feature is active, while red shows that the feature is not in use. 

 

TimeEvents 

The TimeEvents  option enables/disables the Scheduled Stacks  feature, which allows you to load pre-
saved Stacks  at scheduled times throughout the day/week. 
 
To display the  Scheduled Stacks , go to the Edit menu and choose Scheduled Stack Setup.  The window 
below will appear. 

 
 
Scheduled Stack Setup is covered more in depth in the chapter titled Scheduled Stacks. 
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Level Meters 

If the sound card you’re using provides a Windows MME compliant Peak Meter control (such as our 

recommended AudioScience cards) then WaveCart will display the audio level on each deck’s level 

meters.  Most domestic and many semi-pro sound cards do not provide a Peak Meter control. 

 

Timers 

Each deck has three timers; an Intro countdown is displayed in blue, the Elapsed time is 

shown in green, and the Remaining time is shown in red. 

 

Deck Label 

When loaded, the play deck label will 
display the audio filename, Artist & Title 

information together with (depending on 

the display height chosen) the OutCue, 

Length, Intro, Segue, File Type, 

Category, Start Date, and End Date.  

While playing, the label background turns Green. 

When a deck is paused, it turns Cyan and (if Attempt Segues is checked) will automatically 

start when the deck before it reaches the Segue point. 

While a deck is fading out (if the pertinent fade options have been configured), the label turns Yellow. 

WaveCart will also look at the Start and End Date of an audio file and warn you that the audio file is not 

valid for play by turning the background color Red.  WaveCart will not prevent you from playing the file 

though.  The label will also be turned Red when an error situation occurs, such as attempting to load an 

audio file that can not be found. 

Double-clicking on the deck label will perform a search of the currently displayed audio list for the 

currently loaded audio file.  If a cart is loaded in the deck, double-clicking on the label will search for the 

cart file, but holding down the Shift key and double clicking will search for the current audio file from that 

cart. 

Hovering the mouse cursor over the artist or title fields will pop-up a tool-tip with the file name of the 
currently loaded audio file 

When a Cart is loaded, the Cart logo will be displayed in the upper 
right corner of the deck label.  If that deck is not currently playing, 

single left-clicking on the icon will load the next item in the cart.  

Double left-clicking on the icon will reload the next-to-play event 

for non-randomized carts.  Right clicking on the icon will open the 

currently loaded cart in the Cart Editor.  

Hovering the mouse cursor over the cart icon will pop-up a tool-tip with the file name of the currently 

loaded cart. 
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Play Controls 

The touch-screen compatible 

Play Controls allow you to 

Play, Pause and Stop a file.  (If 

the file is already stopped, you 

can Eject the deck). 
 

Audio List Controls 

By default, the Audio List will show the contents of all 

folders monitored by SoundHound.  Using the drop down 

box you can limit the audio list display to any single folder 

that SoundHound is monitoring. 

 

 
Using the Find button, you can search the 
Audio List for a particular phrase (for 

example, Artist or Title). 

 

 

Status Bar 

The Status Bar provides a handy visual reference to the play position of each of the decks.  Clicking on 

any of the deck position indicators will cause the deck stack to scroll to that deck if your current WaveCart 

window isn’t showing all decks on the screen at once. 

 

Menus 

File  

• Open Stack – Opens a previously saved Stack of play decks  

• Save Stack – Saves the currently loaded Stack of play decks  

• Save Stack As – Allows you to save the current Stack of play decks with a different name  

• Exit – Shuts down WaveCart 
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Edit 

• New Cart – To create a new Virtual Cart, click this option 

• Edit Audio File – Opens your (optional) Audio Editor application, such as Adobe Audition.  (The 

path to this must be setup in the Program Options).  

• Edit Audio Info – Launches the BSI Info Editor allowing you to store additional information 

inside the audio file itself  

• View Event Logs – WaveCart will optionally keep track of every audio file played in either ASCII 

or Microsoft Access format.  Use this option to select and view any Event Log.  

• HotKeys Setup – Launches the HotKeys setup allowing you to select the Current and StartUp 

HotKeys sets.  

• Triggers Setup – Launches the Triggers Setup  

• Scheduled Stacks Setup – Opens the Scheduled Stack Loading Configuration window 

• Find – Allows you to search the Audio List for a phrase (such as Artist or Title)  

• Find Again – Searches the Audio List for the next instance of a phrase 

Tools  

• Update Folder List – Refreshes the audio folders and the Audio List with the current 

SoundHound data. 

• AutoStep – Activates automatic sequencing of the decks  

• HotKeys – Displays the current HotKeys Palette  

• Loop – If decks are not cleared after they have played, then WaveCart will sequence from deck 1 

to 10 and then restart deck 1 again and loop the decks.   

• Triggers – Turns on or off incoming Triggers  

• TimeEvents – Enables or disables the Scheduled Stack Loading features. 

• Deck Height – Adjust the height of the Play Decks  

• Clear Decks – Unloads all decks  

• Pause All Decks – Pauses all currently loaded decks, allowing them to sequence automatically if 

the relevant options are selected  

• UnPause All Decks – Clears pause and places decks into stopped mode.  Decks will no longer 

automatically sequence  

• Program Options – Displays WaveCart's Program Options  

Window  

• Optimize Display – Maximizes the number of decks displayed on screen based on your screen 
resolution. 
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• Show Pass-Through Control – Shows or hides the Pass-Through Mute button 

Help  

• WaveCart Help – Opens the Help File  

• Technical Support – Opens your default Web Browser and navigates to the BSI Support Centre 

(requires Internet Access)  

• Security – Allows access to WaveCart's Security Options  

• Register – Validates your Hardware Key with the provided Validation Code to prevent WaveCart 

shutting down every few minutes  

• About – Display the Registration Status and WaveCart Version. 

Audio List (Right-Click Menu) 

• Play – Auditions the highlighted file   

• Edit Info – Launches the Info Edito  

• Edit Audio – Opens your (optional) Audio Editor  

• Delete – Permanently deletes the currently highlighted file  

• New Cart – Creates new Virtual Cart  

• Refresh List – Refreshes the audio list (forcing a database refresh)  

• Sort By – Sorts the audio list using any one of the following parameters: 

Artist/Advertiser 

Category 

Description 
End Date 

Length 
Name 

Start Date  

• Ascending – Sorts the list in Ascending order  

• Descending – Sorts the list in Descending order  

• Show Details – Toggles whether full or limited details of each audio file are displayed  

• Change list font – Allows you select a different Windows font for the Audio List 

Play Deck (Right-Click Menu)  

• Quick Load – Allows you to quickly enter a known filename to load into the selected deck  

• Scrubber – Opens up a scrubber allowing you to navigate 

through the audio file.  Click the X to close the scrubber. 
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About 

The Help > About menu option displays information about WaveCart including the full version number 

and registration status. 

 

You can also view the full License Agreement from this screen. 
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Cart Viewer 
As well as audio files, WaveCart supports the use of Virtual Carts (the ability to store multiple audio 

files in a single file).  Within WaveCart (and BSI Simian) Virtual Carts are often abbreviated to Carts but 

are otherwise identical.   

Events inside a virtual cart can either be played individually, with the next (or optionally random) file 
played next time the cart is played...or multiple events can be played 'back-to-back' (but not overlapped).  

Launch the Cart Viewer from the Audio List's right-click menu or right-click any existing cart (colored 

green in the Audio List).  You can also open the Cart Viewer using the Edit > New Cart or CTRL+R 

shortcut. 

 Create a new blank cart by clicking the New Cart icon and drag files from the Audio List into the cart. 

 

Using the Edit menu, you can Cut, Copy, or Paste files within a cart. To make an individual item in a cart 

next to play, use the Edit > Make Next option. 

If you need to play multiple events in a cart back-to-back (it is not possible to overlap items within a cart, 

only between different carts and / or audio files) use the + key on each subsequent event you want to 

play.  (The first item in a cart cannot have a + mark otherwise the cart would loop continuously). 

In the example below, three events will play each time the cart is used.  You can toggle the + mark with 
the + key on your keyboard. 

 

Before saving the cart, select the cart Properties from the Save Dialog, or File > Properties menu.  
Although the information is optional, it's helpful to enter as much information as possible as it can be 

useful in the future. 
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Average Length 

Although optional, it's useful to enter an accurate value here so that when the Audio List is sorted, the 

cart is displayed in the correct position. 

Carts are colored green in the Audio List. 

 

Randomize 

Events within a virtual cart can be randomized.  This makes them ideal for things like rotating liners, 
jingles, filler music, etc. 

When the randomized option is selected, each time the cart is played a random event will be selected 
from those events in the cart that have not already been played.  When all events have been played, the 

process is restarted. 

As carts are written to each time they're played (to update this information) it's important to ensure that 

carts are in a folder of their own.  Otherwise, each time a cart is played it could trigger a SoundHound 

refresh of your entire music library. 
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Play Hooks Only 

When this option is selected, WaveCart will only 

play the section of the song in the cart that you 

have designated as the Hook using the Info Editor 
tool.   

Utilizing this feature provides the opportunity to 
forward sell songs that are coming up by dragging 

a selection of upcoming songs into a cart and 
selecting the Play Hooks Only option. 

 

Copy Text 

Although originally intended to display live copy for spots, WaveCart customers around the World have 

also found other novel uses of embedding textual information into their audio files which is displayed 
when the file is played. 

For example, the latest Weather or Traffic Reports 

can be displayed when the relevant bed is played; 

or the latest news headlines when the News 

Sounder fires. Or you could embed liner notes for 
all your latest play list songs. 

The information displayed is embedded into the 

audio file using the Info Editor Copy field.  

Any information entered into that field can be displayed each time that file is played.  Just activate the 

option from the main Program Options. 
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Event Log 
WaveCart will optionally create an Event Log of every audio file played. 

When Spots are being played using WaveCart, the Event Log can form the basis of your Affidavit or might 

be useful during trouble-shooting, etc. 

To view previously created logs, select the Edit > View Events Logs option from the main menu 

and then select the date you want to view (your computer regional date settings should be set to Month, 

Day, Year).  

 

WaveCart can produce Microsoft Access compatible logs, or plain ASCII text files which are pipe delimited. 
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HotKeys 
As well as WaveCart's 10 play decks, there are an additional 24 HotKeys which are played using the F1 

to F12 and SHIFT+F1 to SHIFT+F12 buttons on your keyboard, or from the HotKeys palette. 

To view the HotKeys palette, click Tools > HotKeys from the main menu.  You can re-size the palette 

horizontally if you find that, as in the example below, not all the HotKey names fit in the default space 

provided. 

 

WaveCart supports multiple Hotkeys Palettes which are setup from the Edit > HotKeys Setup 

menu. 

 Click the New HotKeys Set icon to create a new 
set... 

 ...or open an existing HotKeys Set to modify it. 

Assign the HotKeys by dragging files from the Audio 

List. (F13 to F24 refer to the SHIFT+F1 to SHIFT+F12 
buttons). 

 To remove a previously assigned event, highlight it 

and click the Clear HotKey Event icon. 

 Click the Save HotKeys Set button when 

finished. 

Use the drop down boxes to select the Current 

HotKeys and the HotKeys set loaded when 

WaveCart is restarted. 
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Scheduled Stacks 

The Weekly Scheduled 

Stacks feature will load 

stacks that you have created 

automatically on the days of 

the week, at the times you 
specify.  For holidays or out-

of-the-ordinary days, the 

Scheduled Stacks feature 

offers an additional set of 

schedulable fields for 

Alternate Scheduled Stacks.  

This feature is useful for 
users whom use WaveCart 

for very simple automation, 

or for station ID 
replacement on translator 

stations. 

To schedule a Weekly 

Scheduled Stack, select one 
of your stacks from the 

Stack Path/Name dropdown, 

and then click into the Time 
field.  You will be presented 

with a pop-up window that  
 

allows you to select your desired time.  Once you have selected the time, place check marks into your 

desired days in the Day of the Week column. 

Repeat the above process for each stack you wish to load at the scheduled time. 

When you anticipate a holiday or special 

day that uses different stacks than your 
normal weekly schedule, you can set up 

scheduled stacks on the Alternate 
Scheduled Stacks page.  To access this 

page, click on the Show Alternate 

Scheduled Stacks button shown in the 
above image. 

To schedule an Alternate Scheduled Stack, 
select your desired stack from the Stack 

Path/Name dropdown column, click in the 

Time field and select a time from the pop-
up, then select the date on which you wish 

to load the stack. 

Note that when you set an Alternate 

Scheduled Stack on a particular date, all 

Weekly Scheduled Stacks will be ignored 
on that date.  
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Registration 
To purchase a copy of WaveCart, visit http://www.bsiusa.com.   

IMPORTANT NOTE: WaveCart requires a Hardware Dongle; please ensure that you have installed the 

Sentinel Driver and inserted the USB Hardware key before registering the program.   

Once you have purchased your copy of WaveCart, you will be provided with a USB Hardware Key and 

corresponding Validation Code.  

You need to Register the program with the Validation Code to prevent the program shutting 

down every few minutes.   

1. Select Help > Register from the main menu  

2. Check that Your serial number matches the one written on the tag attached to your Hardware 

Key and enter all your information shown on the screen below. 

  

3. Enter validation code as provided with your hardware key.  Click Done when finished.  

4. WaveCart is now registered (you can check on the Help > About screen and will no longer shut 

down every few minutes. 
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Security 

To prevent users having access to all of 

WaveCart’s features, you can optionally 

password protect some of the main menu 

options. 

To setup WaveCart's security options, click 

Help > Security from the main menu.  The 

first time you do this, you'll be asked to choose 

a Security password.    

PLEASE DO NOT FORGET THIS PASSWORD AS YOU CANNOT MODIFY THE SECURITY 

SETTINGS WITHOUT IT! 

Make a note of your chosen password in safe place, enter is twice as directed, and click OK when done. 

 

Security Options 

• Hide FILE menu – This hides the main File menu and removes all the options, including 

the ability to shut down WaveCart. 

• Hide TOOLS menu – This hides the main Tools menu and removes all the options, 

including the Program Options.  As hiding this menu also removes the shortcut to 

pause or clear all decks, most users are likely to choose to hide the [Program] options 

only.  

• Hide [PROGRAM] OPTIONS menu – Rather than restrict use of all the features available 

on the Tools menu, selecting this option will just hide the Program Options menu. 

• Change Password – From time to time, you may wish to 

update the security password.  Please make a careful note 

of the new password and update your records as you will 
not be able to access the security settings without the 

password. 
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Stacks 

WaveCart can save and recall stacks of decks, 

making it easy to save, load, and reuse frequently 

used collections of carts or event entire spot 

breaks. 

When Stacks are saved, you can optionally 

enter additional information such as an Air Date 

together with Description and additional 

comments. 

This information is then displayed in the File > 

Open Stacks menu option. 
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Triggers Sets 
Using an optional hardware device, WaveCart can respond to up to 24 incoming Triggers. 

Supported hardware devices include legacy DIO 24 cards from Computer Boards / Measurement 
Computing, the BSI Trigger Kit using a PMD/USB-1024LS, legacy ASI 4346 and 4336 cards, and the 

Current ASI 5211 model. 

The number of available triggers is determined by the hardware device used; the BSI Trigger Kit provides 

the full 24 triggers, the ASI 4346 and 4336 cards support 16 triggers, and the ASI 5211 card supports 2 

triggers. 

To setup triggers, select the Edit > Triggers Setup option from the main menu. 

 Click the New Triggers Set icon to create a new set... 

...or open an existing set using the Open Triggers Set icon   

Use the drop down Macro list to select a desired action for an incoming trigger. 

 Drag the Macro to the Triggers Set using the Drag Macro to Triggers icon. 

 To remove an individual trigger, highlight it and click the Clear Trigger Event icon 

 When finished, click the Save Triggers Set icon 

 

Select the Startup Triggers and Current Triggers using the drop down boxes. 
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Program Options 
To setup WaveCart's Program Options select Tools > Program Options from the main menu. 

General 

 

Station ID 

This field allows you to customize the display in the title bar of WaveCart.  This could also be 

used as reminder of your station's strap line. 

 
 

 

Startup Settings 
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Use these options to select which features are active when WaveCart is started. These options 
can also be turned on and off while WaveCart is running. 

• Triggers – When checked, WaveCart will respond to incoming Triggers  

• Loop – WaveCart will be placed into Loop mode, continously sequencing play decks 

• Details – Audio List Show Full Details selected 

• AutoStep – Play Decks will automatically sequence 

• Deck Height – Selects the vertical size of the Play Decks. 

System Options 

• Event Logging – Activates WaveCart's built-in Event Log 

• Attempt Segues – If supported by your sound card, WaveCart attempt to overlap play decks 

when in AutoStep mode.  The next deck will be started when the Segue point of the previously 
playing deck is reached.   

• Fade Deck on Segue – Enabling this option will fade the currently playing deck when its segue 

point is reached and start the next deck playing. 

• Default Segue – If no Segue Marker has been placed in the audio file, the default segue length 

is used. 

• End Event Behavior – Usually, it's desirable to Clear Deck to prevent replay of the same event.  

The Reload Deck option is useful when WaveCart is in Loop mode, perhaps with randomized 
carts, to provide a continous audio feed. 

Text Settings 

• You can customize the font and font size when the Display text when cuts are played option is 

selected.  This display any text entered in the Copy field of the audio file using Info Editor. 

Deck Labels 

• Display Cut Labels During Cart Play – This option forces the Play Deck label to display the 

audio file information from within the cart, rather than the generic Virtual Cart information. 

• Auto-Scroll Long Labels – With this option enabled, if the text in a deck’s display label is too 

wide, it will automatically scroll so you can see the full text.  Several scroll styles are available 

from the Auto-Scroll dropdown. 

Event Logging Type 

• Selects the format of the Event Log, either plain text ASCII, or Microsoft Access format. 

SoundHound Settings 

• Use SoundHound 

Unless another BSI application is already running SoundHound on your PC, then this option 
should be checked.  WaveCart will continue to work if SoundHound is not running, but will not 

add any new files to the Audio list. 
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Paths 

 

Audio file paths are setup using the SoundHound utility, selecting the Use friendly names in folders 

lists option displayed the friendly name in the Audio Folder List instead of the full file path.  

 

• Other Paths – Allows you to set paths to a different audio database, an optional Audio Editor 
(not supplied) and folders for Event Logs and Stacks. 
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Playback (Legacy version for Windows XP) 

NOTE: The version of the Playback Tab shown below will only be displayed when running Stinger on 
computers running Windows XP.  For setup on Windows 7 or later, see the next section: Playback Tab 
(Version for Windows 7 or later). 

The Playback tab allows you to assign 
a different wave out device or sound 

card for each of the Play Decks, the 

HotKey & Trigger Decks and the Audio 
list Preview Deck. 

It is not uncommon to only use two 
wave out devices for the main play 

decks, routed to two different physical 
outputs, with odd decks assigned to 

one output and even decks to the 

other - with a domestic on-board 
audio card routed to a pair of PC 

speakers for audition / preview 
purposes.   

However, WaveCart supports a 

different output for each of the 10 on-
screen and two hidden decks 

(HotKeys/Triggers deck & Preview 
deck).  The capability of your sound 

card will determine how many files can 

be played back at the same time and 
how many different devices are 

available.  

 

The Fader Settings section allows you to 

configure the faders controls that WaveCart 
will use for each play device.  Clicking on the 

Configure Fader Assignments button will 

display the pop-up window as shown at 
right. 

Select a play device from the Playback 
Device dropdown and then set the 

corresponding Mixer and Fader 

Assignment for that device.  Repeat the 
above steps for each playback device 

available in the Playback Device dropdown 

list, and then click OK to save the changes.  

The Fade Out When Stop Button Pressed option will cause a playing deck to fade out over the 
duration specified by the Stop Button/Spacebar fade out length (ms) field.  While the fade-out is 

occurring, you can press the Stop button again to instantly stop the deck, or press the Play button to 

cancel the fade-out and return the volume to the percent specified in the Default Volume Level (%) 
field. 

The Maximum Fade Length (ms) field specifies the absolute maximum amount of time any fade-out is 
allowed to take. 
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Playback (for Windows 7 and later) 

NOTE: The version of the Playback Tab shown below will only be displayed when running Stinger on 
computers running Windows 7 or later.  For setup on Windows XP, see the previous section: Playback 
Tab (Legacy Version for Windows XP). 

The Playback tab allows you to assign 
a different wave out device or sound 

card for each of the Play Decks, the 

HotKey & Trigger Decks and the Audio 
list Preview Deck. 

However, WaveCart supports a 
different output for each of the 10 on-

screen and two hidden decks 

(HotKeys/Triggers deck & Preview 

deck).  The capability of your sound 

card will determine how many files can 

be played back at the same time and 

how many different devices are 
available. 

Commonly, the playback decks will be 

set to use the same physical play 

device (or even decks to one play 

device, and odd decks to another if 
manual fading of playback from your 

console is desired). Either way, with 

the new audio engine WaveCart uses 
when Windows 7 or later is detected, 

multiple decks can use the the same 
physical audio device and still all play 

at the same time, or you can set each 

deck to a different physical device if 

desired. 

 

The Fade Out When Stop Button Pressed option will cause a playing deck to fade out over the 
duration specified by the Stop Button/Spacebar fade out length (ms) field.  While the fade-out is 

occurring, you can press the Stop button again to instantly stop the deck, or press the Play button to 
cancel the fade-out and return the volume to the percent specified in the Default Volume Level (%) 

field. 

The Maximum Fade Length (ms) field specifies the absolute maximum amount of time any fade-out is 
allowed to take. 
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Hardware 

 

Hardware Selection 

The drop down box allows you to select which optional hardware trigger device you are 

using.  WaveCart supports the Measurement Computing DIO 24 boards (no longer 
available) as well as the current USB-1024LS devices used with the BSI Trigger Kit.  

Although no longer available, support also remains for customers with AudioScience 

4336/4346 with 16 integrated triggers.  WaveCart also supports the new ASI 5211 audio 

card with 2 integrated triggers. 

The selected option will determine how many triggers are available. 

When using a BSI (USB) Trigger Kit, you must select the Instacal Board #. 

Trigger Test Indicators 

These buttons will turn green momentarily if an incoming trigger is received.  The buttons 

can also be clicked to test a trigger assignment. 

Ignore Subsequent Triggers 

If you find your self receiving erroneous triggers, or you just want the triggers to not 

respond to any further triggers for a certain amount of time after an initial trigger is 
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received, enable the Ignore Subsequent Triggers option and set the time to a desired 
ignore time period. 

Keyboard De-Bouncing 

If you find that keys are accidentally being double-pressed, you can configure the 
Keyboard De-Bouncing  option to ignore keyboard presses that occur more often than a 
specified length of time.  Simply enable the Ignore Subsequent Key Strokes  check box, 
and set the time selector to the desired number of milliseconds. 

Spacebar Behavior While Playing 

Use this option to determine what effect pressing the Spacebar has when a deck is 
playing. 

Audio Mode 

NOTE: This section is only displayed on Windows XP and Windows 7 32bit systems 
running the Legacy audio engine.  On systems using the new audio engine, these settings 
don’t apply and therefore are not displayed. 

• Standard – This is the default audio mode, requiring multiple play streams (or multiple 
sound cards) in order to overlap files. 

• DirectSound – When DirectSound mode is selected, then providing your sound card has 

full (not emulated) DirectSound support (and DirectSound is available on your PC) you 

can overlop multiple audio files using a single audio device even if your audio card 

usually only allows a single audio file to be played at the same time.   

• Force use of software CODEC – WaveCart supports playback of Linear PCM (.wav), 

ADPCM, MP3 and MPEG Layer 3 file formats.  If a format is not directly support by your 

audio card, this option forces audio to be played through an optional Windows ACM 

codec instead.  Most modern PCs are supplied with an MP3 codec, but you may need 

to purchase a special MPEG Layer 2 ACM codec from BSI to support playback of MPEG 

Layer 2 (including Content Depot) files. 
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Network 

 
 
The network tab allows you to configure the host settings to allow connections from WaveCart Remote 
clients and configure MetaData Control  to allow you to have WaveCart automatically perform actions 
based on received MetaData (IE: data from an automation system, or other TCP/UDP based data source).  
There are also Incoming IP Address Filters  available, should you want to limit connections to only 
certain incoming IP addresses.  For more info on the WaveCart Remote application, see the section titled 
WaveCart Remote Client  in this manual. 
 

WaveCart Remote Connections 

This section is used to configure your settings for use with the WaveCart Remote application to allow 
remote clients to connect to and control your WaveCart host.  The Connection Password  field allows you 
to set up a password which the remote user must use to log in to your WaveCart host. 
 
The number entered into the TCP Port  field determines what TCP/IP port your WaveCart host will listen to 
for remote connections.  By default, WaveCart will listen to port 6500. 
 
The Enable File Transfer Functions  option allows remote client users to transfer audio files from their 
machine into the audio library, and even directly into a playback deck.  The port the file transfer function 
uses is 1 higher than the TCP Port configured (6501 by default), but can be configured to any port desired 
by choosing the Manually Select Port  option and entering the desired port number into the available field. 
 
The Data Refresh Rate  drop-down allows you to set how often the WaveCart Host will send update 
information, including the VU meter state, the deck labels, and the application labels.  If you have a slow 
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connection, or your internet service provider charges by the amount of bandwidth, you may want to set the 
data refresh rate to a lower value.  Conversely, if you have a fast connection and don’t have a bandwidth 
cap on your internet connection, you can set this value higher.  This setting does not effect the reaction 
speed of asynchronus functions like clicking on the play or stop buttons, just the refresh rate of the data 
types mentioned above. 
  

Incoming IP Address Filters 

If the IP addresses of your remote clients or MetaData 
sources are static, you can set up Incoming IP Address 
filtering.  With this option enabled, WaveCart will only allow 
incoming connections from the IP addresses specified, and 
reject all others. 
 
You can enable or disable IP filtering for either the remote 
clients, or the meta-data control functions. 
 
To add your desired IP addresses to the filter, click on the 
Set IP Filters  button and the window at right will appear.  
Enter your desired IP addresses into the fields, then click 
Done.  NOTE: wild cards are not allowed, the IP addresses 
entered must be the full, valid IP address. 

 
 

Incoming MetaData Control 

The Incoming MetaData Control  function allows you to set up WaveCart to be controlled by TCP or UDP 
data sources.  With this option enabled and configured, WaveCart will listen to the desired port for specific 
“watch strings”, and take the specified actions when a watch string is found in the data stream.   
 
The list of watch strings is processed in sequential order from top to bottom, so you can implement simple 
logic functions by using the Stop Processing Further Watch Strings  function and the When 
Present/When Not Present  function modifier.   
 

 

The screen-shot of the WaveCart Setup – Network tab shown at the start of this section 
implements a station ID & commercial replacement technique that will mute the configured 
pass-through mixer and start playing the current stack when the watch strings 
“CATEGORY=ID” or “CATEGORY=ADV” are found in a metadata stream, and will stop 
playing the stack when neither the “CATEGORY=ID” nor “CATEGORY=ADV” watch strings 
are detected in the metadata stream.  This is the type of setup used when using WaveCart 
Pro for  station ID replacement on a translator/repeater station. 

 
To configure a Watch String, type the text string (a “string” is a word or sentence of alpha/numeric text) 
into an available Watch String field, then select the function you want WaveCart to perform when that 
string is encountered from the Function  dropdown.  You can reverse the logic of the watch string by 
setting the function modifier to When Not Present , rather than When Present , so that the function is 
performed when the Watch String specified is not found in a metadata stream. 
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Serial 

For WaveCart to communicate with a peripheral via the serial port, you’ll need to configure a number of 
different options that may be required by your particular peripheral. Start by going to Tools/Program 
Options and selecting the Serial tab. 
 
The information needed to set up serial communications options is available from your peripheral’s 
manufacturer. 

 
Figure 3.32 

Port  — Choose your preferred 
communication port setting.  Valid options 
are COM1 through COM4. 

Baud Rate  — Choose the baud rate.  Valid 
rates range from 300 to 28,800. 

Parity — Choose the parity setting.  This is 
the method of byte validation.  Valid options 
are Even, Odd, Mark, or Space. 

Data Bits  — Choose the data bit transfer 
rate.  Valid options are 4 through 8. 

Stop Bits  — Choose the stop bit rate.  Valid 
options are 1, 1.5 and 2.  

Flow Control  — Choose the flow control 
setting.  Valid options are Hardware, None, 
XOn/XOff, as well as Both Hardware and 
XOn/XOff. 

Input Terminator  — Choose CR (Carriage Return), LF (Line Feed), or CR/LF. 

Output Terminator  — Choose CR, LF or CR/LF. 

DTR — This is a non-standard hardware-level option that is sometimes required by an external device. 
Normally set for Low (disabled). 

RTS — This is a non-standard hardware-level option that is sometimes required by an external device. 
Normally set for Low (disabled).  
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Metadata 

Configuring HTML Output 

To post your play list on the World Wide Web, you need a browser and Internet access.  If you don’t have 
Internet access yet, you can still play with this feature and have a page displayed to anyone who’s on your 
computer network or intranet. 
 
We’re assuming you don’t have FrontPage or any other fancy html editor.  If you do, this will be even 
easier. 
 
WaveCart has two HTML page generators.  Each HTML page generator requires a source (or template) 
page, and a destination page.  WaveCart recreates the destination page every time a playback deck starts 
playing a new audio file using the template page.  Therefore, you should only edit the template page as 
the destination page will be overwritten the next time a playback deck starts.  The destination page is 
constantly deleted and rewritten automatically. 
 
The BSI_Sample_Page.htm and BSI_Templage_Page.htm files included with Simian are intended as 
demo pages – we hope you will be creative and edit these or make your own custom pages! 
To use a Dynamic HTML Page generator, simply follow these instructions: 

1. Go to Tools/Program Options , and then go to the Metadata  tab and select the HTML tab 

2. Enable either the Dynamic HTML 1  or the Dynamic HTML 2  options to “turn on” one of the 
HTML generators 

3. Select “C:\BSI32\BSI_Sample_Page.htm” or “C:\BSI32\BSI_Template_Page.htm” for the 

Template (Source) Filename  field by clicking on the  button 

4. Manually type “C:\BSI32\BSI_Destination_Page.htm” into the Destination File Name  field (you’ll 
have to manually type this path/filename because the file won’t exist) 

5. Close the WaveCart Program Options dialog box by clicking on the OK button. 

6. Start Playback of an audio file on one of the play decks. 

7. Go to C:\BSI32 and double-click BSI_Destination_Page.htm. This will open the destination page 
in your default Internet browser. 

Watch the Destination page and as you play events from your program log.  Notice how the Dynamic 
HTML Page reloads with the information of the currently playing song.  
 
Now, go get the person who writes your web page, because we're going to go Web Geek for a little 
while… 
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Dynamic HTML Pages For The Web Geek:Dynamic HTML Pages For The Web Geek:Dynamic HTML Pages For The Web Geek:Dynamic HTML Pages For The Web Geek:    

The Dynamic HTML function of WaveCart is similar 
to a mail merge…except that it merges the 
information of the currently playing events into an 
HTML template file.  You do not need to keep the 
Dynamic HTML Page in its current form. In fact, 
we'd rather have you customize it. Therefore we're 
going to give you the lowdown on how it works. 
If you open WaveCart and go to Tools/Program 
Options, then select the HTML tab on the 
Metadata  tab.  You'll see a set of options for 
Dynamic HTML. 
 
Dynamic HTML 1 / 2  – Turns on the Dynamic 
HTML generators for either of two templates.  
 
Template (Source) Filename  – Simian writes the 
Template file and then automatically copies it to 
the Destination file. You'll want to edit the 
Template. 

 
Figure 4.60 

 
Destination (Output) Filename  – This file is automatically overwritten with the Template file information. 
You'll want to put this file on your local web server. 
 
Automatically FTP HTML file  – To upload your HTML file to an FTP site each time your HTML page is 
updated, enable this option.  Click on the FTP Settings…  button and you will be presented with the 
window shown in figure 4.60 so you can configure your FTP server’s settings. 

 
Figure 4.61 

You will need to enter your FTP server’s URL or IP 
address into the FTP Server Address  field, and the 
port your FTP server is using (default is 21 for FTP 
servers).  The Username and Password for your FTP 
account will need to be entered into the 
corresponding fields as well.  The FTP Server 
Destination field is the directory your HTML page will 
be placed into.  You can leave this field with only a 
back-slash if you want the file uploaded into the root 
directory of your account, or you can enter a relative 
path if you want the HTML page uploaded into a sub-
folder on the server.  If your FTP server uses Passive 
Mode to transfer files, place a check box into the 
Server Uses Passive Mode  check box, otherwise, 
leave the option unchecked. 

 

 

If you are unsure of weather your FTP server uses passive mode or not, you can try it both 
ways.  If uploading your file fails while this option is unchecked, try again while it’s checked.  
You won’t hurt anything by trying either mode, your upload may just fail if the option doesn’t 
match your server’s mode. 

 
Default URL  – You can associate a URL with the different audio files so that you can set up spots to link 
to their advertisers. You define the URL in the audio file tag for the audio file. If no URL is specified, 
Simian will use this URL. 
 
Default Artist / Advertiser  – If the current event does not have an artist entered in its tagging info, the 
text entered in this field will be used instead. 
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Default Title / Description  – If the current event does not have a title entered in its tagging info, the text 
entered in this field will be used instead. 
 
Exclude Categories  – To keep Simian from sending tags for certain kinds of Events, enable this option 
and configure the Exclude Categories settings on the Categories tab. 
 
Recent Events / Coming Up  – These set the number of items coming up and those recently played that 
will be written when you use the Recent and Coming Up tags. 
 
Encode HTML in Files  – Replace special characters with corresponding “escape characters” to properly 
conform to HTML standards. 

HTML TagsHTML TagsHTML TagsHTML Tags    

This is the bread and butter for the web developer. You can enter any of the tags below into your code. 
 
The tags available are: 
 

• Current Artist/Advertiser <!--BSIARTIST--> 
• Current Description/Title <!--BSITITLE--> 
• Current Event   <!--BSICURRENT--> 
• Current File Name  <!--BSICURRENTFILE--> 
• Current Album   <!--BSIALBUM--> 
• Current Category  <!--BSICATEGORY--> 
• Current Comments  <!--BSICOMMENTS--> 
• Current Composer  <!--BSICOMPOSER--> 
• Current Copy   <!--BSICOPY--> 
• Current Copyright  <!--BSICOPYRIGHT--> 
• Current Duration  <!--BSILENGTH--> 
• Current Genre   <!--BSIGENRE--> 
• Current Publisher  <!--BSIPUBLISHER--> 
• Current / Default URL  <!--BSIURL--> 
• Current Item Year  <!--BSIYEAR--> 
• Recent Events   <!--BSIRECENT--> 
• Recent Events – Short  <!--BSIRECENT1--> 
• Recent File Names  <!--BSIRECENTFILES--> 
• Station ID   <!--BSISTATIONID--> 
• (For compatibility, tags used in other BSI products will be recognized and left empty.  This makes 

it possible for you to use the same template with WaveCart and Simian, and it’ll just work) 
 
Now that we've gone over the controls, let’s go over how this works. WaveCart reads the Template file 
and looks for its proprietary tags. It then replaces those tags with the appropriate information from the 
currently playing audio file. It then copies the file over top of the previous Destination file. This means that 
you can edit the existing Template page, or create a new one and drop in the tags from the HTML Tag 
Generator.  
 
If you do not have a web server in-house and use a service provider, you will need to upload the 
destination file each time the template file is updated.  You can use the built in Automatically FTP HTML 
File  option, as explained earlier, or any of a number of third-party FTP applications that can automatically 
transfer your file when a change is detected. 
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Configuring Streaming (HTTP call) Metadata Output 

WaveCart can send artist, title, file length (among 
other fields) data to your internet stream encoder 
by HTTP calls when a new audio file starts playing 
from your program log.  In addition to allowing you 
to set up custom HTTP output profiles, there are 
pre-configured profiles for ShoutCast, IceCast, and 
SAM Cast. 
 
To configure ShoutCast, IceCast, or SAM Cast, 
enable the profile by clicking on the checkbox to 
the left of the corresponding profile.  Enter the IP 
address or URL to your encoder, then a colon, and 
finally the port number your encoder is monitoring 
into the URL/Port field (see Figure 4.62 for an 
example).  You may need to consult your encoder's 
settings, your stream service provider, IT person, or 
the encoder's manual for the URL and port number 
info. 

 
Figure 4.62 

 
To have invalid URL characters encoded as their “escape character” counterpart, enable the Encode 
Stream Encoding Metadata (use URL entities)  option.  For example, spaces will be replaced by “%20” 
when this option is enabled. 
 
To configure other services – such as Live365, or others – that do not have a preconfigured HTTP output 
profile, there are two steps: 

1. Enter the IP address/URL and port number required to access your stream encoder into one 
of the three Custom profiles' URL/Port field.   

2. Modify the corresponding entry in the “Encoder Data.ini” file contained in C:\BSI32\ for the 
remainder of the URL required by your stream encoder. 

To create your custom URL string, Meta Variables can be used to represent the data fields from your 
audio tracks.  Meta Variables are replaced at run-time with the actual data from the audio track that is 
playing.  Below is a list of the available Meta Variables. 
 

• %ARTIST%  Artist/Advertiser field 
• %TITLE%  Title Description field 
• %ALBUM%  Album field 
• %CATEGORY%  Category field *(see note regarding SAM Cast) 
• %LENGTHMILS%  Audio file duration in milliseconds 
• %LENGTHSECONDS% Audio file duration in seconds 
• %LENGTH%  Audio file duration in mm:ss 
• %FILENAME%  Physical filename of audio file 
• %PASSWORD%  Password entered in the corresponding HTTP output profile 
• %USERNAME%  Username entered in the corresponding HTTP output profile 
• %URL%   URL field 
• %PUBLISHER%  Publisher field 
• %COMPOSER%  Composer field 
• %GENRE%  Genre field 
• %YEAR%  Year field 
• %COMMENTS%  Comments field 
• %STATIONID%  Station ID field 
• %COPY%  Copy field 
• %COPYRIGHT%  Copyright field 
• %DESC%  Description field 

 
 



BSI WaveCart 5.1 Pro Manual 

Page 40 
 

Example:  
http://192.168.1.90:8888 along with the username and/or password (if required by your stream 
encoder) would be entered in the Custom 1  field on the Streaming  tab of WaveCart’s Program 
Options.  
/?user=%username%&pass=%password%&artist=%artist%&title=%title%&image=%URL% would 
be entered after the “Custom1=” line in the EncoderData.ini file. 

 
*SAM Cast  uses single letter categories of "S", "A", "P", "J", and “I” to represent 
Song, Advertisement, ID, Commercial, etc.  For the SimpleCast profile only, 
WaveCart will automatically convert the following common full word categories to the 
corresponding single letter categories before outputting the HTTP data: 

Category Name as entered in 
WaveCart 

Character replacement befo re 
sending to SAM Cast 

“Audio” S 
“Ad”, “Advertisement”, 
“Comm”, “Commercial” A 

“ID”, “Station ID” I 
“Promo”, “PSA” P 

“Jingle” J 
This is done so that you can leave categories in WaveCart as the easier to work with 
whole word categories while retaining SAM Cast's category functionality.  Note that 
only the specifically listed categories above are automatically translated.  All other 
categories are passed through as given. 
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Configuring TCP/UDP Metadata Output 

Should you have the need to output artist, title, category, etc. data to an RDS, Stream Encoder, or other 
device via UDP or TCP, WaveCart offers TCP/UDP Metadata output functionality (commonly referred to 
as PAD data).  Before using this function, you must create a template file.  The Metadata function utilizes 
a user-created template to structure the output data. 
 
There are also two built-in templates to work with Orban Optimod and Omnia AXE encoders.  Simply 
enable either of these options and set your IP address and Port number (which need to match your 
configuration in your Optimod or AXE device’s setup). 

Creating a TCP/UDP Metadata TemplateCreating a TCP/UDP Metadata TemplateCreating a TCP/UDP Metadata TemplateCreating a TCP/UDP Metadata Template    
To create a Metadata template, you will need an ASCII text editor (such as Notepad, which is included 
with your Windows operating system).   Use the Meta variables from the table below to build your your 
PAD output file (see Figure 4.63 for an example, %ARTIST%, %TITLE%, and %URL% are meta-variables 
used). 

• %ARTIST%  Artist/Advertiser field 
• %TITLE%  Title Description field 
• %ALBUM%  Album field 
• %CATEGORY%  Category field *(see note regarding SimpleCast) 
• %LENGTHMILS%  Audio file duration in milliseconds 
• %LENGTHSECONDS% Audio file duration in seconds 
• %LENGTH%  Audio file duration in mm:ss 
• %FILENAME%  Physical filename of audio file 
• %PASSWORD%  Password entered in the corresponding HTTP output profile 
• %USERNAME%  Username entered in the corresponding HTTP output profile 
• %URL%   URL field 
• %PUBLISHER%  Publisher field 
• %COMPOSER%  Composer field 
• %GENRE%  Genre field 
• %YEAR%  Year field 
• %COMMENTS%  Comments field 
• %STATIONID%  Station ID field 
• %COPY%  Copy field 
• %COPYRIGHT%  Copyright field 
• %DESC%  Description field 

Example:  
Template: 

 
Figure 4.63: PAD template before song data is merged 

Merged Output: 

 
Figure 4.64:  PAD Output file after song data is merged (output 
is sent via UDP/TCP, not merged to a file.  This is for example 
only) 
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Configuring TCP/UDP Metadata SettingsConfiguring TCP/UDP Metadata SettingsConfiguring TCP/UDP Metadata SettingsConfiguring TCP/UDP Metadata Settings    

After you have created your template file as outlined above, you will need to configure WaveCart’s 
Metadata options to utilize your file and let WaveCart know where and how it is to send your data. 
 
Template File Name  – click on the “…” 
Browse Button  to browse to, and select 
your PAD data template file (these usually 
have an .xml extension). 
 
IP Address  – Enter the IP address or URL 
to your encoder (or other device) that you 
want to send your PAD data to. 
 
Port  – Enter the port your encoder (or 
other device) is monitoring for PAD data. 
 
UDP / TCP selection  – Select the 
communication type, either UDP or TCP.  
Note that TCP can cause delay/timeout 
issues if the address and port specified 
are not accessible. 
 
Replace Excluded Categories with 
Default Fields  – If you would like to 
exclude data from categories of your 
choosing, enable this option after 
configuring the Exclude Categories. 

 
Figure 4.65 
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Configuring Serial Metadata Output 

Should you have the need to output artist, 
title, category, etc. data to an RDS 
encoder or other device via serial port, 
WaveCart offers Serial Metadata output 
functionality.  Before using this function, 
you must create a Serial Output String.  
The Serial Metadata function utilizes a 
user-created “string” (A.K.A. sentence) to 
structure the output data. 
 
Use plain text, along with the Meta 
variables from the table below to build 
your output string. For example, 
%ARTIST% and %TITLE% are meta-
variables used in figure 4.66. 
 

 
Figure 4.66 

 
• %ARTIST%  Artist/Advertiser field 
• %TITLE%  Title Description field 
• %ALBUM%  Album field 
• %CATEGORY%  Category field *(see note regarding SimpleCast) 
• %LENGTHMILS%  Audio file duration in milliseconds 
• %LENGTHSECONDS% Audio file duration in seconds 
• %LENGTH%  Audio file duration in mm:ss 
• %FILENAME%  Physical filename of audio file 
• %PASSWORD%  Password entered in the corresponding HTTP output profile 
• %USERNAME%  Username entered in the corresponding HTTP output profile 
• %URL%   URL field 
• %PUBLISHER%  Publisher field 
• %COMPOSER%  Composer field 
• %GENRE%  Genre field 
• %YEAR%  Year field 
• %COMMENTS%  Comments field 
• %STATIONID%  Station ID field 
• %COPY%  Copy field 
• %COPYRIGHT%  Copyright field 
• %DESC%  Description field 

 
 
You will also need to configure the serial port settings in the fields provided.  These settings will depend 
on the device you are sending this data to.   
 
Note that if you have selected the same port number on the Serial Metadata tab as you have selected on 
the main Serial tab (the serial port settings used by the available serial trigger devices), the settings will be 
grayed out.  In that case, both the trigger hardware and the Serial Metadata functions will use the same 
port and the port settings are configured on the Serial tab.  If you want to use a different port for your 
serial trigger device and the Serial Metadata output, ensure that a different port is selected on both tabs 
and configure the port settings accordingly. 
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Configuring Metadata Exclude Categories 

If you are using the HTML Page Generator, 
Streaming Metadata, TCP/UDP Metadata, or 
Serial Metadata, you can configure the Exclude 
Categories so that data from categories of your 
choosing won’t output data.  This means that if 
you don’t want to output data from Station IDs or 
Spots, you could add those categories to the 
Exclude Categories list, then enable the Exclude 
Categories option on your desired metadata 
output types and the data from those categories 
won’t be sent via HTML, Stream, TCP/UDP, or 
serial output. 
 
To configure the Exclude Categories, simply click 
on the Set Exclude Categories  button in the 
lower left corner of the Metadata  tab.  The 
window shown at right will appear.  Simply type in 
the name of the categories of audio files you want 
to exclude from metadata output and click Done .  
Make sure to also enable the Replace Excluded 
Categories with Default Fields  options along 
with the default data fields for each metadata 
output type you wish to adhere to the exclude 
category configuration. 

 
Figure 4.67 
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WaveCart Remote Client 

 
 
The WaveCart Remote Client allows you to connect to a running WaveCart Host to start decks playing, 
load audio files into decks, load stacks, change Scheduled Stack settings, play HotKeys, load HotKey 
sets, load Trigger sets, and more. 
 
The user interface is nearly identical to WaveCart itself.  The main difference being the connection details 
at the top of the Audio List. 

Setup 

To configure the WaveCart 
Remote Client, go to the Tools  
menu and choose Program 
Options . You will be presented 
with the window shown at right. 
 
The Auto-Scroll Deck Stack On 
Play  option will cause the stack of 
decks to scroll automatically if a 
deck is started that is above or 
below the currently visible decks.  
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The Attempt Auto-Connect on Startup  option will cause the WaveCart Remote Client to try to connect 
to a WaveCart Host with the last configured IP address and Port. 
 
With the Remember Password  option enabled, the last successfully used password will be remembered 
and automatically used the next time you connect to a host.  If that password is no longer valid, you will be 
prompted to enter the current one when attempting to connect. 
 
The Use Friendly Names option will cause the folder list displayed above the Audio List to show their 
configured friendly names.  If no friendly name has been configured for a path, or this option is disabled, 
the folder list will display the actual path (the path to the audio file on the WaveCart Host). 
 
The Deck Height  option will determine what deck height mode WaveCart is set to when the application is 
started. 
 
The Hide Audio Meters  option will either show, or hide the VU meters on the left of each playback deck.  
If you don’t need to see meters, or your audio card doesn’t support audio meters, enable this option. 
 
In the Appearance Settings  section, you can set the deck labels to automatically scroll in several 
different styles to show any Artist or Title data that is too long to show in the width of the deck label field. 
 

Use 

To use the WaveCart Remote Client, you must first set up WaveCart (the Host) and enable it to accept 
remote connections.  When configuring WaveCart, you will need to take note of that machine’s IP 
address, the connection port(s) you select to use (the default is 6500 for the remote connection, 6501 for 
file transfer functions), and the password you set. 
 
With your WaveCart Host up and running, and waiting for connections, you can open WaveCart Remote 
on another machine and enter the Host’s IP address and port number into the appropriate fields in the 
upper right corner and click on the Connect  button.  WaveCart Remote will connect to the WaveCart Host 
and download it’s audio file library information (the Artist/Title info, not the actual audio files). 
 
Once the library is downloaded, you will have full control over the WaveCart Host.  You can play, stop, 
pause, load decks, save stacks, edit Scheduled Stacks, play Hotkeys, load Trigger sets, and more! 
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Support 
Technical Support for WaveCart is provided by our online Support Center at http://support.bsiusa.com. 

Information about product updates and answers to common questions are available 24-hours-a-day. 

If our FAQ or User Forum doesn't provide the answers you need, or if you have a problem of a 

technical nature relating to our software or any hardware we have supplied, then please use the links 

provided to submit a Support Ticket.   

We aim to respond to all Support Tickets within 60-minutes during normal weekdays, from 6am to 

6pm (PST). 

Please note that Telephone Support for WaveCart is only available to customers that have 

purchased a Tech Support Plan; and we cannot undertake to diagnose or configure hardware that we 

have not directly supplied. 

  

Copyright 
The copyright and intellectual property rights of this software, WaveCart, and all its documentation, 

including the online help system, are owned by Broadcast Software International and are 

protected by copyright laws and international intellectual property right treaties.  

You may not copy any portion of the software or documentation in any form, except to use this software 
in accordance with the terms of the license agreement or to make one copy for backup purposes.  

You may not alter the software in any way.  

  

 


